Author Topic: Getting jMemorize to work on Windows OS platform?  (Read 1722 times)

0 Members and 1 Guest are viewing this topic.

Offline Taronyu Leleioae

  • Taronyu
  • ****
  • Posts: 521
  • Karma: 16
Getting jMemorize to work on Windows OS platform?
« on: November 11, 2012, 05:44:49 pm »
Has anyone been successful lately in getting jMemorize to work on a Windows OS using the LN word lists?  The program itself runs fine, but when I go to import the .tsv word list, it just errors out immediately.  I dug around the forums.  Found you set your character set to UTF-8.  Thinking that it might just be the english file, I tried the german file but received same results.

I open the program (v1.3.0).  I go to "Import".  Select .tsv file.  Then select the dictionary file.  Then select the UTF-8 character set as recommended elsewhere.  Then I get an error.

(Sample error.)

Ver 1.3.0  (200803122134) - Java 1.7.0_09 , OS Windows XP
java.io.IOException: Unknown header column: 'ampi
   at jmemorize.gui.swing.actions.file.ImportTSVAction. doImport(Unknown Source)
   at jmemorize.gui.swing.actions.file.AbstractImportAc tion.actionPerformed(Unknown Source)

(Debug/error stack continues...)



I've tried XP x86, as well as Windows 7 x86 and x64.  I've fully updated java.  No joy.   :'(


Any suggestions/solutions to this?

Offline Tìtstewan

  • LearnNavi Zeykoyu
  • Toruk Makto
  • Palulukan Makto
  • *****
  • *
  • *
  • Posts: 9804
  • de Germany
  • Karma: 321
  • Ke lu oeru kea krr krrtalun!
    • My YouTube Channel
Re: Getting jMemorize to work on Windows OS platform?
« Reply #1 on: November 11, 2012, 06:13:18 pm »
I have the same problem at Windows 7 x64. I tryed to import a .csv file, but I get an error too.

-| Dict-Na'vi.com | Na'viteri Files | FAQ | LM | Puk Pxaw 'Rrta | Kem si fu kem rä'ä si, ke lu tìfmi. |-

Offline Tirea Aean

  • The Blue One
  • Olo'eyktan Anawm
  • Palulukan Makto
  • *****
  • *
  • *
  • *
  • Posts: 9847
  • nv Eywa'eveng
  • Karma: 243
  • Oeri ran lu srung
    • Tirea Aean
Re: Getting jMemorize to work on Windows OS platform?
« Reply #2 on: November 11, 2012, 08:45:48 pm »
Has anyone been successful lately in getting jMemorize to work on a Windows OS using the LN word lists?  The program itself runs fine, but when I go to import the .tsv word list, it just errors out immediately.  I dug around the forums.  Found you set your character set to UTF-8.  Thinking that it might just be the english file, I tried the german file but received same results.

I open the program (v1.3.0).  I go to "Import".  Select .tsv file.  Then select the dictionary file.  Then select the UTF-8 character set as recommended elsewhere.  Then I get an error.

(Sample error.)

Ver 1.3.0  (200803122134) - Java 1.7.0_09 , OS Windows XP
java.io.IOException: Unknown header column: 'ampi
   at jmemorize.gui.swing.actions.file.ImportTSVAction. doImport(Unknown Source)
   at jmemorize.gui.swing.actions.file.AbstractImportAc tion.actionPerformed(Unknown Source)

(Debug/error stack continues...)



I've tried XP x86, as well as Windows 7 x86 and x64.  I've fully updated java.  No joy.   :'(


Any suggestions/solutions to this?

This sounds like it's not the program but the input files. Which basically means, it's all my fault. (The .tsv files are generated by me via the LN database, at the same time as I update my vrrtepCLI dictionary set.)

Thanks for bringing this up, I will investigate JMemorize and how it likes its files. I KNOW that it used to work, I must have changed something in my scripts. I'll take a look and get back once I've fixed my scripts and have generated acceptable files.

Ngaytxoa!  :-[

kelku ikranä a hawnventi yom podcast (na'vi-only): https://tirearadio.com/podcast
Learn Na'vi Discord Chat: https://discord.gg/WF6qcmv

Offline Tirea Aean

  • The Blue One
  • Olo'eyktan Anawm
  • Palulukan Makto
  • *****
  • *
  • *
  • *
  • Posts: 9847
  • nv Eywa'eveng
  • Karma: 243
  • Oeri ran lu srung
    • Tirea Aean
Re: Getting jMemorize to work on Windows OS platform?
« Reply #3 on: November 11, 2012, 09:22:56 pm »
My scripts have been accordingly fixed, and the JMemorize files have been uploaded and replaced. Try downloading them again, and import the new ones. :)

I seem to have forgotten that the first line of a JMemorize file MUST read:

"Frontside"    "Flipside"    "Category"

kelku ikranä a hawnventi yom podcast (na'vi-only): https://tirearadio.com/podcast
Learn Na'vi Discord Chat: https://discord.gg/WF6qcmv

Offline Tìtstewan

  • LearnNavi Zeykoyu
  • Toruk Makto
  • Palulukan Makto
  • *****
  • *
  • *
  • Posts: 9804
  • de Germany
  • Karma: 321
  • Ke lu oeru kea krr krrtalun!
    • My YouTube Channel
Re: Getting jMemorize to work on Windows OS platform?
« Reply #4 on: November 11, 2012, 10:46:28 pm »
Good job, ma Tirea Aean! :)
Irayo!

-| Dict-Na'vi.com | Na'viteri Files | FAQ | LM | Puk Pxaw 'Rrta | Kem si fu kem rä'ä si, ke lu tìfmi. |-

Offline Tirea Aean

  • The Blue One
  • Olo'eyktan Anawm
  • Palulukan Makto
  • *****
  • *
  • *
  • *
  • Posts: 9847
  • nv Eywa'eveng
  • Karma: 243
  • Oeri ran lu srung
    • Tirea Aean
Re: Getting jMemorize to work on Windows OS platform?
« Reply #5 on: November 11, 2012, 11:00:20 pm »
Good job, ma Tirea Aean! :)
Irayo!

:D Assuming everything works now?

kelku ikranä a hawnventi yom podcast (na'vi-only): https://tirearadio.com/podcast
Learn Na'vi Discord Chat: https://discord.gg/WF6qcmv

Offline Tìtstewan

  • LearnNavi Zeykoyu
  • Toruk Makto
  • Palulukan Makto
  • *****
  • *
  • *
  • Posts: 9804
  • de Germany
  • Karma: 321
  • Ke lu oeru kea krr krrtalun!
    • My YouTube Channel
Re: Getting jMemorize to work on Windows OS platform?
« Reply #6 on: November 11, 2012, 11:05:14 pm »
Good job, ma Tirea Aean! :)
Irayo!

:D Assuming everything works now?
For me it works. :D
The English and the German version tested.

Edit: error fix
« Last Edit: November 11, 2012, 11:13:00 pm by Tìtstewan »

-| Dict-Na'vi.com | Na'viteri Files | FAQ | LM | Puk Pxaw 'Rrta | Kem si fu kem rä'ä si, ke lu tìfmi. |-

Offline Taronyu Leleioae

  • Taronyu
  • ****
  • Posts: 521
  • Karma: 16
Re: Getting jMemorize to work on Windows OS platform?
« Reply #7 on: November 12, 2012, 06:17:12 pm »
Successfully tested english .tsv file on XP x86 and Windows 7 x86.

I've been trying for the last couple of months to get it to work without luck.  (I wasn't looking to find fault btw...)  I know with apps that changes happen and functionality breaks.  I did have a hunch that it was database coding related looking at the beginning of the stack trace.  But with a development program (from SourceForge) and a custom dictionary that has caused issues with quotations, etc... in the past, one is never sure where the actual problem really is.  Glad it was an easy fix.

Now I can take it with me on the plane in a few weeks.  Irayo.
« Last Edit: November 12, 2012, 06:39:59 pm by Taronyu Leleioae »

 

Become LearnNavi's friend on Facebook Follow LearnNavi on Twitter! Watch LearnNavi's videos on YouTube

SMF 2.0.15 | SMF © 2017, Simple Machines
Privacy Policy
| XHTML | RSS | WAP2 | Site Rules

LearnNavi is not affiliated with the official Avatar website,
James Cameron, or the Twentieth Century-Fox Film Corporation.
All trademarks and servicemarks are the properties of their respective owners.
Images in the LearnNavi.org Forums and Gallery may not be used without permission.

LearnNavi Affiliates:
ToS

LearnNavi is the community to learn Na'vi, the Avatar Language
"A place where real friendships are made." -Paul Frommer

AvatarMeet | Learn Na'vi Forum | Learn Na'vi Wiki | Na'viteri

LearnNavi