Author Topic: Cloudflare/CDN Issues  (Read 9035 times)

0 Members and 1 Guest are viewing this topic.

Offline Kxeyo

  • Palulukan Makto
  • *****
  • *
  • Posts: 1624
  • Karma: 30
  • Home is where the horse is.
Cloudflare/CDN Issues
« on: August 30, 2013, 02:06:37 pm »
I'm not seeing any images and it's been this way since the outage, I do believe. You know, it's not just user content but basic simple machines stuff. If I didn't know how to type bbcode, I would now not be able to use it because all the buttons are gone.
Oe lu Kxeyo—

—pa'liyä maktoyu.

Actually, that would be an interesting thought; if gay Na'vi would actually mate, or just run off in the bushes for a little bum-fun!

Kxa (Open your mouth and say "Kxa") :P

🐴

Offline Toruk Makto

  • LearnNavi Admin
  • Toruk Makto
  • Palulukan Makto
  • *****
  • *
  • Posts: 6031
  • us United States
  • Karma: 211
  • . Txepsiyu Markì .
    • Learn Na'vi
Cloudflare/CDN Issues
« Reply #1 on: August 30, 2013, 02:14:37 pm »
I'm not seeing any images and it's been this way since the outage, I do believe. You know, it's not just user content but basic simple machines stuff. If I didn't know how to type bbcode, I would now not be able to use it because all the buttons are gone.

What browser are you using?  I enabled SPDY on CloudFlare and it may be interfering with some web clients.

EDIT: I just made a change on the image compression setting. Please let me know if that fixed the problem...
« Last Edit: August 30, 2013, 02:18:57 pm by Toruk Makto »

Lì’fyari leNa’vi ’Rrtamì, vay set ’almong a fra’u zera’u ta ngrrpongu
Na'vi Dictionary: http://eanaeltu.learnnavi.org/dicts/NaviDictionary.pdf

Offline Tìtstewan

  • LearnNavi Zeykoyu
  • Toruk Makto
  • Palulukan Makto
  • *****
  • *
  • *
  • Posts: 9704
  • de Germany
  • Karma: 318
  • Ke lu oeru kea krr krrtalun!
    • My YouTube Channel
Cloudflare/CDN Issues
« Reply #2 on: August 30, 2013, 02:45:49 pm »
I just want to mention that:
[smg id=5213]
Flash videos will not loaded by first page visit. I have to do a refresh by F5 button to see it.

-| Dict-Na'vi.com | Na'viteri Files | FAQ | LM | Puk Pxaw 'Rrta | Kem si fu kem rä'ä si, ke lu tìfmi. |-

Offline Alan

  • Olo'eyktan
  • Palulukan Makto
  • *****
  • *
  • Posts: 2906
  • gb United Kingdom
  • Karma: 30
Cloudflare/CDN Issues
« Reply #3 on: August 30, 2013, 03:02:44 pm »
Ooo...the lights have dimmed a little.  Irayo for trying to keep them on ma Toruk Makto.

The only thing is that everybody's Avatars appear to have disappeared, including some of the images....oh and all the little message editing thingies as well All I can do is change colour...blue is fitting though!.

Think a bit more unobtainium needs shovelling into the boiler!

Alan

Offline `Eylan Ayfalulukanä

  • Palulukan Makto
  • *****
  • *
  • *
  • Posts: 4682
  • us United States
  • Karma: 44
  • Palulukan alu Kenya 06/23/1996 - 01/15/2017
    • The Lionlamb website
Cloudflare/CDN Issues
« Reply #4 on: August 30, 2013, 03:05:37 pm »
Will putting a UPS on the server really do anything for you unless the network infrastructure out to the internet also has similar protection? I am thinking that in this scenario, even if your server stayed up, the rest of the network would have been down.

Ma Taronyu Leleioae, I have seen breakers through at least 400 amps, and maybe 800 amps, that are just simple mechanical breakers. This was in 480 volt service. A 1600 amp breaker at the last station I worked at was of the 'pump-up' type like seen in 'Jurassic Park'. The energy from the 'pump-up' was stored mechanically in the breaker, for tripping.

The really high energy breakers I have encountered over the years, used for the beam supplies of klystron TV transmitters, were mostly vacuum contactors. These are interesting devices, designed to break the load at the next zero crossing of the AC line after opening, as the vacuum could not sustain any kind of arc. These were extremely fast, to protect the delicate body structure inside the tube from arcs or magnet misfocusing. Older RCA klystron transmitters used a huge mechanical contactor that weighed over 500 pounds. And you could feel it in the building floor slab when these contactors operated! General Electric used their AK-15 line of mechanical contactors for the same purpose. These were complex beasts that required periodic maintenance, and were known to suddenly explode...

Alan, I actually have a big analog voltmeter over my desk here at work, that shows me what the AC mains are doing. They still use analog meter movements for this, as they respond well to line voltage variations.

Oh, and BTW, as far as I can tell, all site features are working normally, including on the Dothraki side.

Yawey ngahu!
pamrel si ro [email protected]

Offline Alan

  • Olo'eyktan
  • Palulukan Makto
  • *****
  • *
  • Posts: 2906
  • gb United Kingdom
  • Karma: 30
Cloudflare/CDN Issues
« Reply #5 on: August 30, 2013, 03:22:58 pm »
How strange.  :-\  On my old computer the IE browser didn't shown LN properly, but IE on my new computer does....although I tend to use firefox, which shows LN fine :o ???.  Go figure!  :D :D

Alan

Offline Toruk Makto

  • LearnNavi Admin
  • Toruk Makto
  • Palulukan Makto
  • *****
  • *
  • Posts: 6031
  • us United States
  • Karma: 211
  • . Txepsiyu Markì .
    • Learn Na'vi
Cloudflare/CDN Issues
« Reply #6 on: August 30, 2013, 03:25:32 pm »
Will putting a UPS on the server really do anything for you unless the network infrastructure out to the internet also has similar protection? I am thinking that in this scenario, even if your server stayed up, the rest of the network would have been down.

Well, it was just the cabinet power on our row and just the PDU we were on. Just lucky I guess. The network was still there.

Lì’fyari leNa’vi ’Rrtamì, vay set ’almong a fra’u zera’u ta ngrrpongu
Na'vi Dictionary: http://eanaeltu.learnnavi.org/dicts/NaviDictionary.pdf

Offline Toruk Makto

  • LearnNavi Admin
  • Toruk Makto
  • Palulukan Makto
  • *****
  • *
  • Posts: 6031
  • us United States
  • Karma: 211
  • . Txepsiyu Markì .
    • Learn Na'vi
Cloudflare/CDN Issues
« Reply #7 on: August 30, 2013, 03:28:32 pm »
How strange.  :-\  On my old computer the IE browser didn't shown LN properly, but IE on my new computer does....although I tend to use firefox, which shows LN fine :o ???.  Go figure!  :D :D

Alan

Well, now that we are on a proper CloudFlare Pro account, I turned on some performance stuff that is supported by modern browsers about 6 hours before the power failure. I am pretty sure that is what is causing some people some trouble.  Everything I have here has displayed all the sites correctly, so I wasn't aware there was a problem.

Lì’fyari leNa’vi ’Rrtamì, vay set ’almong a fra’u zera’u ta ngrrpongu
Na'vi Dictionary: http://eanaeltu.learnnavi.org/dicts/NaviDictionary.pdf

Offline Taronyu Leleioae

  • Taronyu
  • ****
  • Posts: 521
  • Karma: 16
Cloudflare/CDN Issues
« Reply #8 on: August 30, 2013, 03:29:29 pm »
 I would make the dangerous assumption that the main network backbone is on UPS.  Although with all the horrors Markì has put up with at that co-location facility, I'd rather go bet on Powerball.  IMO, I never really care if the site goes down (scary for a sysadmin...), I only worry about saving the drives and integrity of the database.  Playing Gran Turismo with hard drives and the controller is never a good game...  The only real issue with any rack UPS, is that if it really trips, someone has to go hit the ON button.  Hence changing the batteries out.  (But buy them elsewhere, not APC who charges double.)

Nods.  I've had to actually trip some of those modern pump-up breakers.  I've scared the crap out of people (and myself) when you push the trip button and it throws you back.  Let alone the fact that everyone within 100K feet building has heard and felt it go.  I've only seen, not worked around klystron transmitters up in Andover Maine what the international site was operational by Bell and MCI to receive the original Telstar and (I think...) Intelsat 7 satellites over Europe.  Anyway, digressing.  I agree.  Lots of power and something you didn't even want to touch with a fibreglass pole if you could help it.

Offline archaic

  • Palulukan Makto
  • *****
  • Posts: 2960
  • Karma: 73
  • Trying again with the language.
Cloudflare/CDN Issues
« Reply #9 on: August 30, 2013, 03:33:12 pm »
I'm not seeing any images and it's been this way since the outage, I do believe. You know, it's not just user content but basic simple machines stuff. If I didn't know how to type bbcode, I would now not be able to use it because all the buttons are gone.
The only thing is that everybody's Avatars appear to have disappeared, including some of the images....oh and all the little message editing thingies as well All I can do is change colour...blue is fitting though!.

No images here neither, but can still change color just fine. What gives already?
The Dragon Affair my current fanfic - now complete.

The Dragons Clutch, my last fanfic, non Avatar related.

Machine, my last Avatar related fanfic.

Offline Toruk Makto

  • LearnNavi Admin
  • Toruk Makto
  • Palulukan Makto
  • *****
  • *
  • Posts: 6031
  • us United States
  • Karma: 211
  • . Txepsiyu Markì .
    • Learn Na'vi
Cloudflare/CDN Issues
« Reply #10 on: August 30, 2013, 03:48:45 pm »
I will keep disabling options until we find the one that is stomping the images.  I just backed the caching depth to it's minimum level.  Can somebody check now?

Lì’fyari leNa’vi ’Rrtamì, vay set ’almong a fra’u zera’u ta ngrrpongu
Na'vi Dictionary: http://eanaeltu.learnnavi.org/dicts/NaviDictionary.pdf

Offline Clarke

  • Taronyu
  • ****
  • Posts: 505
  • Karma: 8
  • This is gonna be great
Cloudflare/CDN Issues
« Reply #11 on: August 30, 2013, 03:59:57 pm »
Ooooh, intriguing. Everything works fine for me... except if Javascript from Cloudflare is switched off. ???

EDIT: Except I seem to have accidentally nuked my own avatar. Oops.

EDIT (again): I think something's broke in the kit that lets you select from the preset avatars.

Offline Toruk Makto

  • LearnNavi Admin
  • Toruk Makto
  • Palulukan Makto
  • *****
  • *
  • Posts: 6031
  • us United States
  • Karma: 211
  • . Txepsiyu Markì .
    • Learn Na'vi
Cloudflare/CDN Issues
« Reply #12 on: August 30, 2013, 04:16:13 pm »
Ah ha! That is the static preloader. If folks can figure out how to allow CF javascript, I would really like to keep that feature turned on since it seriously speeds up page load times...

Lì’fyari leNa’vi ’Rrtamì, vay set ’almong a fra’u zera’u ta ngrrpongu
Na'vi Dictionary: http://eanaeltu.learnnavi.org/dicts/NaviDictionary.pdf

Offline Clarke

  • Taronyu
  • ****
  • Posts: 505
  • Karma: 8
  • This is gonna be great
Cloudflare/CDN Issues
« Reply #13 on: August 30, 2013, 04:44:00 pm »
Really? I didn't notice, although I have FF setup to parrarelize my connection anyway. Would it be possible for it to gracefully degrade?

Also, I think Cloudflare is getting in the way of avatar updates. I tried to change mine, even by way of selecting no avatar and putting a different one, and the previous one showed up.

Offline Ftiafpi

  • Olo'eyktan
  • Palulukan Makto
  • *****
  • *
  • Posts: 4757
  • Karma: 123
  • Plltxe 'eylan ulte fpxäkìm.
Cloudflare/CDN Issues
« Reply #14 on: August 30, 2013, 07:31:18 pm »
No problems loading images from me running Firefox (latest).

Offline Toruk Makto

  • LearnNavi Admin
  • Toruk Makto
  • Palulukan Makto
  • *****
  • *
  • Posts: 6031
  • us United States
  • Karma: 211
  • . Txepsiyu Markì .
    • Learn Na'vi
Cloudflare/CDN Issues
« Reply #15 on: August 30, 2013, 07:52:32 pm »
Really? I didn't notice, although I have FF setup to parrarelize my connection anyway. Would it be possible for it to gracefully degrade?

Also, I think Cloudflare is getting in the way of avatar updates. I tried to change mine, even by way of selecting no avatar and putting a different one, and the previous one showed up.

I think we figured that one out. It takes 4 hours for the cache to expire and then the new one will show.


Lì’fyari leNa’vi ’Rrtamì, vay set ’almong a fra’u zera’u ta ngrrpongu
Na'vi Dictionary: http://eanaeltu.learnnavi.org/dicts/NaviDictionary.pdf

Offline `Eylan Ayfalulukanä

  • Palulukan Makto
  • *****
  • *
  • *
  • Posts: 4682
  • us United States
  • Karma: 44
  • Palulukan alu Kenya 06/23/1996 - 01/15/2017
    • The Lionlamb website
Cloudflare/CDN Issues
« Reply #16 on: August 30, 2013, 09:07:09 pm »
BTW, what exactly does Cloudflare do? I noticed it is active on the Dothraki side, as well.

At the moment, everyone's avatars pictures have disappeared. I hope they are back after the Cloudflare chache expires.

Yawey ngahu!
pamrel si ro [email protected]

Offline Toruk Makto

  • LearnNavi Admin
  • Toruk Makto
  • Palulukan Makto
  • *****
  • *
  • Posts: 6031
  • us United States
  • Karma: 211
  • . Txepsiyu Markì .
    • Learn Na'vi
Cloudflare/CDN Issues
« Reply #17 on: August 30, 2013, 09:33:41 pm »
Ok, I have turned off image optimization for both domains... Let's see what that does.

Lì’fyari leNa’vi ’Rrtamì, vay set ’almong a fra’u zera’u ta ngrrpongu
Na'vi Dictionary: http://eanaeltu.learnnavi.org/dicts/NaviDictionary.pdf

Offline Toruk Makto

  • LearnNavi Admin
  • Toruk Makto
  • Palulukan Makto
  • *****
  • *
  • Posts: 6031
  • us United States
  • Karma: 211
  • . Txepsiyu Markì .
    • Learn Na'vi
Cloudflare/CDN Issues
« Reply #18 on: August 30, 2013, 09:35:46 pm »
BTW, what exactly does Cloudflare do? I noticed it is active on the Dothraki side, as well.

At the moment, everyone's avatars pictures have disappeared. I hope they are back after the Cloudflare chache expires.

It does two things, it is a content distribution network service and it optimizes the way pages load to reduce the bandwidth and load on the LN server.

Lì’fyari leNa’vi ’Rrtamì, vay set ’almong a fra’u zera’u ta ngrrpongu
Na'vi Dictionary: http://eanaeltu.learnnavi.org/dicts/NaviDictionary.pdf

Offline Tirea Aean

  • The Blue One
  • Olo'eyktan Anawm
  • Palulukan Makto
  • *****
  • *
  • *
  • *
  • Posts: 9643
  • nv Eywa'eveng
  • Karma: 239
  • Can't help helpin'
    • Tirea Aean
Cloudflare/CDN Issues
« Reply #19 on: August 30, 2013, 11:28:14 pm »
Images never stopped working for me. Chrome OS beta channel latest. I do notice that when I first load the forum site, it kinda does weird things for a second before settling. It's just that new way of loading the page.

 

Become LearnNavi's friend on Facebook Follow LearnNavi on Twitter! Watch LearnNavi's videos on YouTube

SMF 2.0.15 | SMF © 2017, Simple Machines | XHTML | RSS | WAP2 | Site Rules

LearnNavi is not affiliated with the official Avatar website,
James Cameron, or the Twentieth Century-Fox Film Corporation.
All trademarks and servicemarks are the properties of their respective owners.
Images in the LearnNavi.org Forums and Gallery may not be used without permission.

LearnNavi Affiliates:
ToS

LearnNavi is the community to learn Na'vi, the Avatar Language
"A place where real friendships are made." -Paul Frommer

AvatarMeet | Learn Na'vi Forum | Learn Na'vi Wiki | Na'viteri

LearnNavi